Lakeland Sales Club Website, product hub, and critical backend services are unavailable.
Resolved
May 10, 2026 at 1:14pm UTC
Everything has successfully recovered.
Affected services
Updated
May 9, 2026 at 4:10pm UTC
Things are recovering.
Affected services
Updated
May 9, 2026 at 1:17am UTC
Backend services are recovering, not everything is functional. Status updates will be provided soon.
Affected services
Created
May 8, 2026 at 12:54am UTC
An issue has been identified relating to the backend logic for Lakeland Services hosting. We will be in contact soon for updates, we are working to migrate to a more reliable hosting provider, which is in the works now.
Affected services