Back to overview
Downtime

LakelandSales Club Website and critical backend services are down.

Feb 12 at 04:49pm EST
Affected services
Lakeland Sales Website
API
Product API

Updated
Feb 12 at 05:03pm EST

We are currently looking out for more infomation, stay tuned.

Created
Feb 12 at 04:49pm EST

Lakeland Sales is currently experiencing an outage, caused by one of our external data providers. An update will be provided once more information becomes available.
No update has been provided yet.